$re = '/.*(txt$)|(html\.txt$)/m';
$str = 'happiness.html
joy.png
madness.html.txt
excitement.txt
fear.src';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);