import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(.)\\1)(?=.*[A-Z])(?=.*[a-z])(?=.*[$@#*\\/&!¿?¡+%()=-])[a-zA-Z](?=.*[0-9])[A-Za-z0-9$@#*\\/&!¿?¡+%()=-]{7}$";
final String string = "W23@r#k8\n"
+ "Xa$4=6/w\n"
+ "Pe4*5v?-\n"
+ "M2%e5(7f\n"
+ "Qsd!Y7a2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}