const regex = /^(?!.*(.)\1)(?=.*[A-Z])(?=.*[a-z])(?=.*[$@#*\/&!¿?¡+%()=-])[a-zA-Z](?=.*[0-9])[A-Za-z0-9$@#*\/&!¿?¡+%()=-]{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(.)\\1)(?=.*[A-Z])(?=.*[a-z])(?=.*[$@#*\\\/&!¿?¡+%()=-])[a-zA-Z](?=.*[0-9])[A-Za-z0-9$@#*\\\/&!¿?¡+%()=-]{7}$', 'gm')
const str = `W23@r#k8
Xa\$4=6/w
Pe4*5v?-
M2%e5(7f
Qsd!Y7a2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}