$re = '/(.+)\1$/m';
$str = 'This is a whole paragraph that shouldn\'t contain any repetition. that shouldn\'t contain any repetition.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);