re = /(.+)\1$/m
str = 'This is a whole paragraph that shouldn\'t contain any repetition. that shouldn\'t contain any repetition.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end