using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":61:(?!.*:86).*?(?=:61:|$)";
string input = @":61:2002190XCOL3654628815//CT505:86:/BENM/Imports/REM//58:61:2002190219C300S103L:V5674//CT56748006:86:/BENM/Gravity Imports/REM//INV/FEB20/446301:61:200219C30000S103LCADV567204//C7007:61:2002190XCOL3654628815//CT505:86:/BENM/Imports/REM//58:61:200219C30000S103LCADV567204//C7006
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}