use strict;
my $str = '08 21 2020 08:32:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:31:58 10.72.1.17 Passwordstate: Successful Active Directory login for UserID \'fakedoamin\\FakeUser\' from the IP Address \'10.72.1.17\'. Client IP Address = 10.72.1.93
';
my $regex = qr/<AUDT:INFO>.(?<date>\d+.\d+.\d+) (?:\d+:\d+:\d+) (?<dip>\d+.\d+.\d+.\d+) (?:.*(?<subject>Successful Active Directory login)(?:.\w+.\w+)(?<account>.*?\W))\w+.\w+.\w+.\w+.'(?<sip>.\d+.\d+.\d+.\d+)'.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}