import re
regex = re.compile(r"<AUDT:INFO>.(?<date>\d+.\d+.\d+) (?:\d+:\d+:\d+) (?<dip>\d+.\d+.\d+.\d+) (?:.*(?<subject>Successful Active Directory login)(?:.\w+.\w+)(?<account>.*?\W))\w+.\w+.\w+.\w+.'(?<sip>.\d+.\d+.\d+.\d+)'.*$", flags=re.MULTILINE)
test_str = ("08 21 2020 08:32:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:31:58 10.72.1.17 Passwordstate: Successful Active Directory login for UserID 'fakedoamin\\FakeUser' from the IP Address '10.72.1.17'. Client IP Address = 10.72.1.93\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")