package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w.]+$`)
var str = `Str
Str1.oozZx1
Str1
str.Str
Str1_Str`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}