$re = '/^[\w.]+$/m';
$str = 'Str
Str1.oozZx1
Str1
str.Str
Str1_Str';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);