# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(..)(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?(..)?"
test_str = "000102030405060708090A0B0C0D0E0F101112131415161718191A1B1C1D1E1F202122"
subst = "\\t0x$1${2:+,0x$2:}${3:+,0x$3:}${4:+,0x$4:}${5:+,0x$5:}${6:+,0x$6:}${7:+,0x$7:}${8:+,0x$8:}${9:+,0x$9:}${10:+,0x$10:}${11:+,0x$11:}${12:+,0x$12:}${13:+,0x$13:}${14:+,0x$14:}${15:+,0x$15:}${16:+,0x$16:}\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.