using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((ftp|http|https):\/\/)|(\/)|(..\/))(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?";
string input = @"http://regex101.com/r/kL2gL2/1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}