re = /(((ftp|http|https):\/\/)|(\/)|(..\/))(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?/
str = 'http://regex101.com/r/kL2gL2/1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end