import re
regex = re.compile(r"(?:INSERT INTO|UPDATE|SELECT|DELETE)(?:[^;'\"]|(?:'[^']*?')|(?:\"[^\"]*?\"))+;", flags=re.IGNORECASE)
test_str = ("String query = \"select * from users_table where username = '\" + u_username + \"' and password = '\" + u_password +\"';\";\n"
"String query2 = \"select * from users_table where username = '\" + u_username + \"' and password = '\" + u_password +\"'\";\n"
"SQLiteDatabase db\n"
"//some un-important code here...\n"
"Cursor c = db.rawQuery( p_query, null );\n"
"return c.getCount() != 0;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")