re = /(?:INSERT INTO|UPDATE|SELECT|DELETE)(?:[^;'"]|(?:'[^']*?')|(?:"[^"]*?"))+;/i
str = 'String query = "select * from users_table where username = \'" + u_username + "\' and password = \'" + u_password +"\';";
String query2 = "select * from users_table where username = \'" + u_username + "\' and password = \'" + u_password +"\'";
SQLiteDatabase db
//some un-important code here...
Cursor c = db.rawQuery( p_query, null );
return c.getCount() != 0;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end