using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\d{1}))(?=(\d{2})?)(?=(\d{3})?)(?=(\d{4})?)(?=(\d{5})?)";
string input = @"12345";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}