$re = '/(?=(\d{1}))(?=(\d{2})?)(?=(\d{3})?)(?=(\d{4})?)(?=(\d{5})?)/';
$str = '12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);