$re = '/([^()\s]+(?=[()])|[^\s()]+|[()])/m';
$str = 'hello world(12)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;