re = /([^()\s]+(?=[()])|[^\s()]+|[()])/m
str = 'hello world(12)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result