import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+[\\+\\-\\*\\/]{1})+\\d+$";
final String string = "5+6+9\n"
+ "4*9+7-8\n"
+ "45++6*6\n"
+ "12+4+\n"
+ "+2-6\n"
+ "2-6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}