import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\:(\\s)?(.+)[^\\{](\\v)";
final String string = "#main h1 {\n"
+ " color: #333;\n"
+ "}\n"
+ "a {\n"
+ " text-decoration: none;\n"
+ " color: #333;\n"
+ "}\n"
+ "a:hover {\n"
+ " text-decoration: underline;\n"
+ "}\n"
+ "body {\n"
+ " margin: 0;\n"
+ " display: table-row;\n"
+ " /*vertical-align: middle;\n"
+ " filter: url(#blur);\n"
+ " background: url('bg.jpg') center top no-repeat #333;\n"
+ " background-clip: cover;\n"
+ " -moz-filter: blur(20px);*/\n"
+ " position: relative;\n"
+ "}\n"
+ "body::before {\n"
+ " content:'';\n"
+ " background: url('bg.jpg') center top no-repeat #333;\n"
+ " background-clip:cover;\n"
+ " background-attachment: fixed;\n"
+ " position: absolute;\n"
+ " top: 0; bottom: 0; left: 0; right: 0;\n"
+ " height: 100%;\n"
+ " width: 100%;\n"
+ " filter: url(#blur);\n"
+ " filter: blur(2px);\n"
+ " -webkit-filter: blur(2px);\n"
+ " z-index: -1;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}