import re
regex = re.compile(r"\:(\s)?(.+)[^\{](\v)")
test_str = ("#main h1 {\n"
" color: #333;\n"
"}\n"
"a {\n"
" text-decoration: none;\n"
" color: #333;\n"
"}\n"
"a:hover {\n"
" text-decoration: underline;\n"
"}\n"
"body {\n"
" margin: 0;\n"
" display: table-row;\n"
" /*vertical-align: middle;\n"
" filter: url(#blur);\n"
" background: url('bg.jpg') center top no-repeat #333;\n"
" background-clip: cover;\n"
" -moz-filter: blur(20px);*/\n"
" position: relative;\n"
"}\n"
"body::before {\n"
" content:'';\n"
" background: url('bg.jpg') center top no-repeat #333;\n"
" background-clip:cover;\n"
" background-attachment: fixed;\n"
" position: absolute;\n"
" top: 0; bottom: 0; left: 0; right: 0;\n"
" height: 100%;\n"
" width: 100%;\n"
" filter: url(#blur);\n"
" filter: blur(2px);\n"
" -webkit-filter: blur(2px);\n"
" z-index: -1;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")