using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$|^[а-яёА-ЯЁ\s]+$|^[а-яёА-ЯЁ\s]+(?=[,;])[,;][а-яёА-ЯЁ\s]+$";
string input = @"Иванов Иван Иванович
Иванов Иван, Петров Петр
Иванов Иван; Петров Петр
Иванов Иван; Петров Петр; Иванов Иван
Иванов И. А.
Иванов Иван, Петров Петр, Сидоров Сидор
Иванов Иван; Петров Петр; Иванов Иван
Иванов Иван; Петров Петр;
Иванов Иван; Петров Петр
Иванов Иван; Петров";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}