import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^$|^[а-яёА-ЯЁ\\s]+$|^[а-яёА-ЯЁ\\s]+(?=[,;])[,;][а-яёА-ЯЁ\\s]+$";
final String string = "Иванов Иван Иванович\n"
+ "Иванов Иван, Петров Петр\n"
+ "Иванов Иван; Петров Петр\n"
+ "Иванов Иван; Петров Петр; Иванов Иван\n"
+ "Иванов И. А.\n"
+ "Иванов Иван, Петров Петр, Сидоров Сидор\n"
+ "Иванов Иван; Петров Петр; Иванов Иван\n"
+ "Иванов Иван; Петров Петр;\n"
+ "Иванов Иван; Петров Петр\n"
+ "Иванов Иван; Петров";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}