const regex = /^(file:\/{3})|(qrc:\/{2})|(http:\/{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(file:\\\/{3})|(qrc:\\\/{2})|(http:\\\/{2})', '')
const str = `http://`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}