$re = '/^(file:\/{3})|(qrc:\/{2})|(http:\/{2})/';
$str = 'http://';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);