using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<tabela>[\S\.-]+)(?:\{)|\t(?P<nome>.*?)\:(?P<tipo>.*?)\:(?P<tamanho>.*?)(?:$)";
string input = @"tabela{
campoA:int:
campoB:str:52
campoC:float:94
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}