// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?P<tabela>[\S\.-]+)(?:\{)|\t(?P<nome>.*?)\:(?P<tipo>.*?)\:(?P<tamanho>.*?)(?:$)").unwrap();
let string = "tabela{
campoA:int:
campoB:str:52
campoC:float:94
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}