import re
regex = re.compile(r"(?<!\d)\d(?!\d)", flags=re.MULTILINE)
test_str = ("Klasse 1a 14/15\n"
"5/66\n"
"1/2/3\n"
"4. Klasse\n"
"Klasse 99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")