package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*\w*\s*style.*?>`)
var str = `<div style="color:#6699cc">round corner</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}