$re = '/<\s*\w*\s*style.*?>/';
$str = '<div style="color:#6699cc">round corner</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);