using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"style\s*=\s*([""'])(.*)\1";
string input = @"<span style=""font-size:0.58em;font-family:'Times New Roman';"">
<span style='font-size:0.58em;font-family:""Times New Roman"";'>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}