import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "style\\s*=\\s*([\"'])(.*)\\1";
final String string = "<span style=\"font-size:0.58em;font-family:'Times New Roman';\">\n"
+ "<span style='font-size:0.58em;font-family:\"Times New Roman\";'>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}