using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(\d+|\d{1,3}(\.\d{3})+)(\,(\s)?\d*)?$";
string input = @"2.359, 66";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}