package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?(\d+|\d{1,3}(\.\d{3})+)(\,(\s)?\d*)?$`)
var str = `2.359, 66`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}