package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[{2}([\w\s()]+)(?:\|([\w\s]+))?\]{2}`)
var str = `"[[December 1]] A triangular [[Conjunction (astronomy)|conjunction]] formed by a new Moon, Venus and Jupiter is a [[Conjunction (astronomy)#2008|prominent sight]] in the evening sky. [[December 2]]"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}