const regex = /\[{2}([\w\s()]+)(?:\|([\w\s]+))?\]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[{2}([\\w\\s()]+)(?:\\|([\\w\\s]+))?\\]{2}', 'g')
const str = `"[[December 1]] A triangular [[Conjunction (astronomy)|conjunction]] formed by a new Moon, Venus and Jupiter is a [[Conjunction (astronomy)#2008|prominent sight]] in the evening sky. [[December 2]]"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}