import re
regex = re.compile(r"""
^(Prefeitura|Pref\.|P\.)\s(Municipal\s?|Mun.\s?|M.\s?)?(de\s)?(S[aã]o\sPaulo|S.\sP.|S.\sPaulo|S.P.|SP)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Prefeitura Municipal de São Paulo\n"
"Prefeitura Municipal de Sao Paulo\n"
"Prefeitura de São Paulo\n"
"Prefeitura de Sao Paulo\n"
"Prefeitura Mun. de São Paulo\n"
"Pref. Mun. de São Paulo\n"
"Pref. Mun. de S. P.\n"
"Pref. de São Paulo\n"
"Pref. de S. Paulo\n"
"Pref. M. de São Paulo\n"
"P. M. de Sao Paulo\n"
"Prefeitura São Paulo\n"
"Pref. Mun. São Paulo\n"
"Pref. Mun. S. Paulo\n"
"Prefeitura de S.P.\n"
"Prefeitura de SP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")