import Foundation
let pattern = #"""
^(Prefeitura|Pref\.|P\.)\s(Municipal\s?|Mun.\s?|M.\s?)?(de\s)?(S[aã]o\sPaulo|S.\sP.|S.\sPaulo|S.P.|SP)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Prefeitura Municipal de São Paulo
Prefeitura Municipal de Sao Paulo
Prefeitura de São Paulo
Prefeitura de Sao Paulo
Prefeitura Mun. de São Paulo
Pref. Mun. de São Paulo
Pref. Mun. de S. P.
Pref. de São Paulo
Pref. de S. Paulo
Pref. M. de São Paulo
P. M. de Sao Paulo
Prefeitura São Paulo
Pref. Mun. São Paulo
Pref. Mun. S. Paulo
Prefeitura de S.P.
Prefeitura de SP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)