# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?://[^/]+/gummybear(?:/?|/?#.*)$"
test_str = ("examples it should be true for\n\n"
"https://www.example.com:81/gummybear/\n"
"http://www.example.com/gummybear#top\n"
"https://example.com:81/gummybear#/foobar/?search=params\n"
"http://www.exa.mple.com:81/gummybear\n"
"https://example.com:81/gummybear/#/exaple/1234/\n\n"
"examples that it should be false for\n\n"
"https://www.example.com:81/foo/gummybear/\n"
"https://www.example.com:81/guMmybear/\n"
"https://www.example.com:81/gummybear.html\n"
"http://www.example.com/gummybear/apple#top\n"
"file://example.com:81/gummybear#/foobar/?search=params\n"
"http://www.exa.mple.com:81/gummybear?search=apple#lol\n"
"https://example.com:81/#/gummybear/\n"
"http://www.test.com:81/dir/dir.2/index.htm?q1=0&&test1&test2=value#top\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.