const regex = /(https?:\/\/(\w+\.)+\w+(\/[\w\-_]+)+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/(\\w+\\.)+\\w+(\\\/[\\w\\-_]+)+)', '')
const str = `check this http://www.newlook.com/shop/womens/dresses/navy-short-sleeve-check-tunic-dress-_320165649 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}