$re = '/(https?:\/\/(\w+\.)+\w+(\/[\w\-_]+)+)/';
$str = 'check this http://www.newlook.com/shop/womens/dresses/navy-short-sleeve-check-tunic-dress-_320165649 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);