const regex = /(?<! [a-z]| [a-z]{2})\.(?! |\d|\.)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<! [a-z]| [a-z]{2})\\.(?! |\\d|\\.)', 'ig')
const str = `This is my example text. After this sentence there is no space after dot.What should? I want PHP to add whitespace in that case, but not after sentence where I already have white space or like now 3times dot...Another thing is that it can be written how great is to win 1.000.000 on lottery but I really don't want it to be 1. 000. 000 after edititng... Also C.J. must stay C.J. and not C. J.... wow that is hard :)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}