import re
regex = re.compile(r"(?<! [a-z]| [a-z]{2})\.(?! |\d|\.)", flags=re.IGNORECASE)
test_str = "This is my example text. After this sentence there is no space after dot.What should? I want PHP to add whitespace in that case, but not after sentence where I already have white space or like now 3times dot...Another thing is that it can be written how great is to win 1.000.000 on lottery but I really don't want it to be 1. 000. 000 after edititng... Also C.J. must stay C.J. and not C. J.... wow that is hard :)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")