import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\h)\n"
+ "(?!.*\\h\\h)\n"
+ "(?!.*-.*-)\n"
+ "(?=(?:.*\\d){9,})\n"
+ "([^(\\r\\n]*\\(?[^)\\r\\n]+\\)?[^()\\r\\n]+)$";
final String string = "\n"
+ "030 12345-67\n"
+ "(030) 12345 55\n"
+ "(030) 12345 44\n"
+ "0351 4640-123\n"
+ "09623 12 3 33\n"
+ "09234 1233\n"
+ "+49 123 1 2 12 31\n"
+ "0049 2123 1231\n"
+ "+1 3519 1231\n"
+ "0 30 / 12 34 56\n"
+ "0 30 / 12 34 56\n"
+ "030 / 12 34 56\n"
+ "0123 / 12312 123\n"
+ "0178 1232231\n"
+ "+490 178 1232231\n"
+ "+36 (351)4740-991\n"
+ "+36(351) 4740-991\n"
+ "09623 12333\n\n"
+ "+49123123123\n"
+ "01781232231\n"
+ "12-12 -12-12-12\n"
+ "1990 - 2000\n"
+ "1990-2000\n"
+ "+36 (351) 47(40-991\n"
+ "+36 (33) 3)4444\n"
+ "234 234 234 234 234\n"
+ "123 123123\n"
+ "01712123123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}