import re
regex = re.compile(r"""
^(?=.*\h)
(?!.*\h\h)
(?!.*-.*-)
(?=(?:.*\d){9,})
([^(\r\n]*\(?[^)\r\n]+\)?[^()\r\n]+)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("\n"
"030 12345-67\n"
"(030) 12345 55\n"
"(030) 12345 44\n"
"0351 4640-123\n"
"09623 12 3 33\n"
"09234 1233\n"
"+49 123 1 2 12 31\n"
"0049 2123 1231\n"
"+1 3519 1231\n"
"0 30 / 12 34 56\n"
"0 30 / 12 34 56\n"
"030 / 12 34 56\n"
"0123 / 12312 123\n"
"0178 1232231\n"
"+490 178 1232231\n"
"+36 (351)4740-991\n"
"+36(351) 4740-991\n"
"09623 12333\n\n"
"+49123123123\n"
"01781232231\n"
"12-12 -12-12-12\n"
"1990 - 2000\n"
"1990-2000\n"
"+36 (351) 47(40-991\n"
"+36 (33) 3)4444\n"
"234 234 234 234 234\n"
"123 123123\n"
"01712123123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")