package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://)?(?:www\.)?[^/]+/[^/]+/`)
var str = `https://www.example.com/uk/exampling/example
https://www.example.com/nz/examping/example`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}