$re = '`^(?:https?://)?(?:www\.)?[^/]+/[^/]+/`m';
$str = 'https://www.example.com/uk/exampling/example
https://www.example.com/nz/examping/example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);