import re
regex = re.compile(r"^Q(?=.*[A-Z])(?=.*\d)[A-Z\d]{7}$", flags=re.MULTILINE)
test_str = ("QC1589ZH\n"
"Q1234567\n"
"QUANTITY\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")