using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(?:w{1,3}.)?[^\s]*?(?:\.[a-z]+)+)(?![^<]*?(?:<\/\w+>|\/?>))";
string input = @"This is my text to be parsed which contains url
http://someurl.com <a href=""http://thisshouldnotbetampered.com"">
some text and a url http://someotherurl.com test 1q2w </a> <img src=""http://someasseturl.com/abc.jpeg""/>
Hello http://someurl.com</a> <!-- fail -->
<img src=""http://someurl.com/image.jpg>
http://someurl.localhost.com
<div>Regex is awesome</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}